ENGRD 241: Engineering Computation
Section 9-3

ENGRD 241
Introduction to Spreadsheets
Section 9-3

Introduction to Spreadsheets: Using Microsoft Excel 

Jery R. Stedinger

School of Civil and Envir. Engineering, Cornell University

January, 2000, updated for EXCEL 2000

CONTENTS 


Introduction

Absolute & Relative Addressing 


Tool Bar

Cell Naming


Have a Question?

Copying and Moving Cells


Workbooks and Worksheets
Saving and Printing Files


Entering Information
Creating Charts


Moving Around

Creating Macros


Selecting Blocks of Cells
Other Useful Macro Information


Formatting

Goal Seeking


Formulas

Solver 


Functions

Numerical Precision 

Other Features

Introduction

This introduction to Microsoft  Excel is designed to be read while you sit in front of a Macintosh or PC running the program.  Excel runs on both PCs and Macintoshes.  The Windows 97, Windows 98 for Macs, and 2000 versions are very similar.  This tutorial should get you started, and give you the sense of its power.  This tutorial is pertinent for Excel 2000, Excel 97, and Excel 98.  

Spreadsheet programs (Lotus 1-2-3, Quattro, Excel) are software that present users with a worksheet or matrix of rows and columns in which text, data, and formulas are stored.  Excel's worksheet, scroll bars, formula bar, and menus are shown below.  They look slightly different with different machines and versions of Excel.

An Excel worksheet can have thousands of rows and hundreds of columns.  An intersection of a row and column is called a cell. Just as elements of an array are described by their row i and column location j, cells are referred to by their row number and column letter:

 A1, B2, C7, G55, AA256, etc.

When selected, a cell becomes the active cell.   In the figure below, cell A1 has been selected, as can be seen because that cell is highlighted.  The cell's name, A1, appears in the formula bar (immediately below the menu and above the worksheet).  If the cell contained text, data, or formulas, they would appear in the formula bar.  Try typing something and editing what you typed by using the cursor in the formula bar to insert or to select different letters or words.  When you have what you want in the cell, press Enter, Tab, Return, or click on the "check" next to the formula bar.
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Tool Bar

Excel allows the user to display and use several tool bars.  (See Toolbars under the View Menu.)  The Window above shows the Standard and Formatting Tool Bars.  They contain a set of powerful buttons that include:
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To open a spreadsheet, open a file, save a file, and print
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Formatting commands specify font, font size, and style: bold, italic, and underline


[image: image4.wmf]  

Modifies cell format so that more or less digits are displayed
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Justification: left, center, right, center across columns
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Border/underline - click on arrow for a matrix of choices
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 Insert a command to sum several rows; insert a function
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ChartWizard for generating charts easily
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HELP!
Have a Question?   Look at Status-Bar, or Use On-line Help

Excel has wonderful help features.  If it hasn’t been turned off (using the Status Bar... item under the View menu), a status bar at the bottom of the screen tells you what is happening, and what Excel expects next.  Most dialog boxes have Help buttons that open Excel’s on-line help.

Detailed information about all Excel features can be obtained using the on-line help.  Double click on the [image: image10.png]e Edt View Insert Format Tools Dots Window telp
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  tool on the Excel Tool bar, or press F1 key, and you enter the on-line help for Excel.  You can search for topics of interest.  Click on underlined words and you go to where that idea is explained further; for dotted underline words, a brief explanation appears.   

Workbooks and Worksheets

A feature of Excel is that each Workbook (an Excel file) can contain several Worksheets.  The window above is called Workbook1 and displays Sheet1.  Every Sheet is another spreadsheet.  However, all of the Sheets in a Workbook are bound together so they do not get separated.  This works well if different sheets refer to each other.  For example, Sheet1 might have raw data, Sheet2 could summarize that data, and Sheet3 can graph the results. Numbers and text can easily be copied between sheets, as they can be between cells on the same sheet, and formulas in one sheet can refer to data on other sheets.  

The arrows along the bottom of the window allow you to scroll the Sheet-tabs if a Workbook has many sheets.  Click on the tab to open that sheet.  Double-click on the tab and a dialogue box opens that allows you to give the sheet a meaningful name.  Under the Edit menu are commands to Delete a sheet, or to Move and Copy Sheet within or between Workbooks.  You can also move a sheet within a workbook by dragging its tab to the desired location, or copy it by holding the option key (Mac; CTRL key under Windows) while dragging the tab.  The Chart Sheets section below describes how to create special sheets containing charts.

Entering Information

Cells may contain numbers, text, or formula.  After selecting a cell, text or numbers can be entered by typing the desired values.  When finished you must press Enter, Return, Tab, or click on the "check" symbol to the left of the formula bar.  To erase what you have started to type, use Delete, or click on the x to the left of the formula bar.  There is also an Undo in the Edit menu, and an undo arrow pointing around-to-the-left on the upper Tool Bar.
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Moving Around

One may move the cursor to select different cells in many ways.  The simplest is (after pressing Enter to finish with the last entry) to point and click with the mouse; use the scroll bars to move to different parts of the worksheet.  You may also use the Arrow keys; or Return to move down, Shift-Return to move up, Tab to move right, and Shift-Tab to move left.  Try it!

Selecting Blocks of Cells

Entire columns and rows are selected by clicking on their row number or column letter.  Rectangular blocks of cells may be selected by clicking on one corner and dragging the mouse-pointer to the opposite corner before releasing the mouse button; alternatively one may click to select one corner, then shift-click on the opposite corner (hold down shift key and click on cell).  To select nonadjacent cells, after selecting the first range, hold down the [image: image12.png]


 key (Mac; CTRL under Windows) while you click and drag to select additional cells.

Formatting

Numbers and text can be displayed in different ways.  The easiest formatting tools for numbers are [image: image13.png]


.  Select the cells containing some numbers, then push on the right two keys to increase/decrease the number of digits displayed.  The $, %, and COMMA keys produce a $-format, a %-format, and a standard display with commas imbedded within the 

numbers.  The format tool bar has buttons 
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 that allow selection of the desired font and font size, as well as buttons that toggle to turn bold on/off, italics on/off, and Underline.

Under the Format menu, one may choose Cells... and specify Number formats (number of decimals, with commas, $-signs, parenthesis for negative dollar quantities, percentages, scientific notation, date formats), Alignments, Fonts (font and style: italic or bold), Borders and Patterns.  Under the Edit menu Clear, one can choose All or Formulas for the selected range of cells.   When one copies one set of cells to another,  the format generally goes along.

A cell's width may be adjusted.  Click on the division between the cells at the top of the worksheet.  (See the pointer symbol change to a double arrow [image: image15.wmf].)  Drag the column divider; or you can double click on the divider and Excel will adjust the column to fit the widest entry.  Alternately, under the Format menu use Column > and then Width or AutoFit.  One can change the height of a row in the same two ways.

Formulas

To enter a formula requires typing an  =  sign as the initial character in the cell.  Formulas perform standard arithmetic operations (+, -, *, /, or  ^ for exponentiation), reference other cells by address or an assigned name (under Insert select Name>), or make use of Excel functions (see below).

Initially Excel displays in the worksheet the values generated by the formula in each cell.  After selecting that cell, one sees the actual formula in the formula bar.  By using, in the Tools menu, Options... (PC; Preferences... for Mac) then View-tab and selecting formulas under "Window Options", one can have Excel's worksheet display the formulas in every cell, rather than the values they generate. 

Functions

Excel has many powerful built-in functions.  In the menu bar use [image: image16.png]


 to activate the Function Wizard:  it brings up a dialog box that allows you to select the category of function that interests you.  Select one from the list and the dialogue box shows you what arguments are required, and also describes what the function does.  After you select Next a second dialogue box allows you to enter the arguments you want (or select them on the worksheet), and displays the function's value.  NEAT!  Here are a few examples of built-in Excel functions:


Mathematical:  ABS(), EXP(), INT(), LN(), LOG(), MOD(),  



GAMMALN(), PI(), RAND(), SIGN(), SQRT(),  SUM(), PRODUCT()



COS(), SIN(), TAN(), ACOS(), ASIN(), ATAN(), ATAN2()



ROUND(), TRUNC(), MIN(),  MAX()


Matrix:  MDETERM(),  MINVERSE(),  MMULT(),  TRANSPOSE()


Logical:  AND(), IF(), NOT(), OR(), TRUE(), FALSE(), 


Statistical:  AVERAGE(), COUNT(), GAMMADIST(), STDEV(),



VAR(), VARP(), TREND(), GROWTH(), LINEST(), LOGEST()



COMBination(), FACTorial(), POISSON(), TTEST(),



 NORMDIST(), NORMINIV(), PERMUT(), RAND()



see also Data Analysis in Tool menu; use Add-In and select ToolPaks to install.>


Financial:  FV(), IRR(), MIRR(), NPER(), NPV(), PMT(), PV()



RATE(), PPMT(), IPMT(), YIELD(), NOMINAL(), EFFECT()


Depreciation:    SLN(), SYD(), DB(), DDB(), VDB()


Text and Numbers: DOLLAR(), FIXED(), SEARCH(), TEST(), VALUE()


Date:  DATE(), DAY(), MONTH(), NOW(), TIME(), WEEKEND(), YEAR()


Special:  HLOOKUP(), LOOKUP(), MATCH(), VLOOKUP()

Putting =SUM(A1:A10) in a cell generates the sum of cells A1 through A10. Entering  =PMT(rate,nper,pv,fv,type) yields the periodic payment for interest rate per period of rate for nper periods which is equal to having pv now and fv at the end of the last period (for the default of type=0 payments occur at the end of periods;  type=1 for payments at the beginning).  Alternatively,  PV(rate, nper, pmt, fv, type) would give the present value for the specified values of the other parameters.  The functions PV, FV, NPER, PMT, RATE form a set.  NPV(rate, v-1, v-2, v-3, . . .) calculates the NPV of any series.

Excel’s array formulas yield results stored in a range of cells, such as MMULT(array-1, array-2);  these formulas are entered by holding the [image: image17.png]


 key when pressing the Enter key (CTRL-Shift-Enter under Windows) SUM(), after selecting the region in which the result will go.  Array commands appear enclosed in braces { }; but Excel adds the braces, not you.

Excel also has a special ToolPak.  Select Data Analysis under Tool menu to learn about and execute ANOVA, Correlation/Covariance, Fourier Analysis, Random Numbers, Regression, Sampling, and t-tests.  You may need to use Add-Ins under the Tool menu to install this capability.

Absolute and Relative Addressing 

Cells may be referred to on a relative basis (using addressed such as C12 or B5) or an absolute basis (with addresses $C12, C$12, or $C$12 -- which are all different).  These concepts are illustrated in the example below.  This is very important when copying cells or using the Fill command (under Edit menu).

In formulas, cells are referenced by typing their relative address, absolute address, or clicking on that cell in the worksheet.  Columns or rows of cells are employed by some functions, such as  =SUM(A1:A10) or =NPV(rate, B4:F4).  The colon denotes the specification of a cell-range.  An array is addressed by it corners, for example A1:C3 describes a 3x3 matrix in the upper right hand corner of the worksheet.

Cell Naming

The name function in Excel allows you to name a single cell or a range of cells to make formulas easier to read and remember.  For example:

· Place the number 3 in cell B1

1a. Select cell B1 and type the name, x, of the cell in the left box. (Note the name of the cell appears in the box) or..

1b. From the Insert menu select Name, then Define.  Name it x.

·  Type the following formula in cell B2



=x^2+3x+24

2. From the Insert menu select Name, Define.  Name this formula form1.

3. In cell B3 type =3*form1

Excel recognizes x as 3 and form1 as the equation typed in step 3.
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Copying and Moving Cells  

Don't type the same material over and over.  Excel is good at copying and duplicating.  For example, if you select a range of cells, and then with the pointer grab the border of that range, you can drag the whole range to a new area to move those entries.  (This is called drag and drop.)  To copy the selected range, hold the Control key down while dragging.  This performs the same function as Copy or Cut and Paste (under Edit menu).

You can Copy selected cells and then Paste them using Edit menu commands.  Using Paste Special in the Edit menu, you can paste the transpose of a selection, or just the format, or just values.

By copying or filling a formula with the right combination of absolute and relative cell addresses, one can construct tables.  (There is also a Table command.)  As an example, we illustrate the generation of a table of the values of  xe for  e equal to 0.5 and 1.5;  we will also plot these functions.  This example will make most sense if you follow along and duplicate the steps using your own computer.  (Excel was set to show formulas by using the Tools menu, Option [PC] or Preferences [Mac], View-tab, and select Formula.)  

Start by putting x in A1, 0 in A2, and 2 in A3.  Then select A2 and drag to include cell A3 also.  Select the lower right corner of the two selected cells and drag it down to cell A10.  This generates a series in cells A3-A10 with the values 0, 2, 4, ...  This illustrates Excel’s ability to quickly generate a series.
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Enter the formulas shown below in cells B2 and C2.  Then select the two cells together.  Next, again grab the little square at the lower right of the two selected cells and drag it down to the tenth row.  This automatically duplicates these formulas in that area.  Alternatively, one could have selected the area B2 through C10, and used Fill > and then Down from the Edit menu to obtain the same result.  

Note that the absolute addresses $B$1 and $C$1 did not change.  However, the relative address A2 in both formulas changed to A3, A4, A5, . . ., A10.  This relative address is understood to mean the cell one to the left (in B2),  or two to the left (in C2).  When the formula was copied, the appropriate new relative address was substituted in each cell.

By going back to Tools menu, Option [PC] or Preferences [Mac], View-tab, and deactivate Formula, make Excel show the calculated values.  Click somewhere else in the worksheet to deselect the whole area to make the data easier to read.   Select the whole area (A1:C10) again; under Format menu use Cell and then Number to make things look nice.  Or else select the cells and use [image: image21.wmf].
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Saving and Printing Files

Save frequently.  You can use the worksheet tool that looks like a disk, or occasionally type  [image: image23.png]


-s (CTRL-s), to avoid losing work if the system crashes.  Sometimes save under a new name, in case you make a mistake and you don't find out about it for a while.  If using Excel 2000 you can back save the file as Excel 97/98.

Print Setup under the File menu allows you to print sideways, and to control margins and the print-area's size, as well as magnification and header/footers; you can also suppress gridlines and column/row headers.  Print using the Print command under the File menu, [image: image24.png]


-p, (CTRL-p), or [image: image25.png]


.  Print Preview under File menu is also nice (or use [image: image26.png]


).

Creating Charts

Excel constructs charts with numbers generated in a worksheet.  Charts and worksheets are linked so that recalculation of the worksheet automatically yields an updated and reformatted chart.  (Deleting and Inserting rows and columns within a data set can cause trouble.)

Let's make an embedded chart with Excel’s ChartWizard.  This is a neat and powerful feature that helps you display data in a wide range of 2- and 3-dimensional formats. Watch this!

0) Select the area containing labels and numbers to be plotted, (A1:C10): click on A1 and drag to C10.  Click on the ChartWizard symbol [image: image27.png]e Edt View Insert Format Tools Dots Window telp
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 .  Excel then needs you to tell it where to store the chart on the worksheet.  Click on cell D1 and Drag to cell G13.  When you release mouse, ChartWizard brings up the first of several dialog boxes.  (With Excel 97/98 you position the graph when you are finished.)

1) ChartWizard asks if this is the correct range for the data.  Click on Next, or press Enter.

2) What chart type?  See figure below with the name ChartWizard - Step 1.  We want a XY(scatter) chart.  Click on this choice.  

3) Choose type of scatter plot.  Select the one that connects points by smooth lines and press the Enter key or the Next button.  

4) See a preliminary view of chart.  But Excel could have guessed wrong about how to interpret information in selected cells.  We want data sets in columns.  Check the data range; add another series if needed.  
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5) Now add chart and axes labels.  Type the title "Sample graph", and press Tab to go to next box for Value (x) Axis; type the x label "Tab"; type the label for Value (y) Axis as "powers of x".   Press Finish and ChartWizard generates the chart. You should see –
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Your graph is stored in the worksheet. You can use window-sizing symbols in the extreme corners or midpoints of the graph’s window to size and proportion your graph, and drag the whole graph by grabbing the chart in the middle.  We are in business!

Sometimes it is nice to have charts stored on their own chart-sheet.  To create a chart sheet instead of placing the chart in the worksheet, select Save As-New-Sheet in step 4 of ChartWizard.  ChartWizard will then create your chart on a new sheet to the left of your data worksheet. 

Double-click in the middle of the graph so we can work on it.  Double-clicking on text brings up dialog box allowing you to change Patterns/Font/Alignment of text.  Double click on the numbers and a dialog box comes up that allows you to select a number format, as well as Font-text styles.  Double-click on either graph line to select that y-series and bring up a dialog box to change the appearance of the line and the symbols used. Edit the column labels to change their appearance in the legend. Make the graph look how you want it.  In the end, you can use Copy to put the chart on the clipboard, and then Paste it in other worksheet, workbooks or MS documents.

Double-click on either axis to select it (or use Axis under the Format menu), and bring up dialog boxes.  Use Scale to control the range of the plot.  You can also make either axis have a logarithmic scale.  By double-clicking on the plot area (or using Format menu and select Plot Area), you can get a dialogue box that allows you to enclose your plot within a border, as is common practice in science.  From the Chart menu, use Chart Options... and select Gridlines or Legend to change those features of the plot.  
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Add text by first clicking on the Text Box from the Drawing Tools toolbar. Then type what you want and press Enter.  Click on any text to select it.  Edit selected text in its box.  You can reshape the box the text is in by dragging one of the handles, or move the whole thing by dragging with the arrow within the box. 

To change the range of the selected data, select your chart and then execute the ChartWizard again.  Have it make the change in range for you.  Or, select the chart and then from the Data menu select Data Source [Excel 97/98].  

With the chart still selected, use Page setup to get ready to print the graph vertically or horizontally, and select border sizes.  You can use Scale to Fit Page, so that the graph will print as large as possible with the same proportions as on the screen.  Finally, with the chart selected, you can select Print to get a hardcopy.

3-D graphs are beautiful, but in most cases they are more impressive than informative.  It is generally best to avoid 3-D unless they really help explain your data.  Pie, Bar, and Column charts are useful in presentations when one has only a few cases whose relative magnitudes should be illustrated.  Line charts are like Scatter plots except the x-categories are always equally spaced and need not be numeric.  

Creating Macros

Microsoft Excel versions 97/98 and 2000 use Visual Basic as the language for generating Macros. 

Visual Basic resembles other structured programming languages.

To create a Visual Basic macro with Excel 2000 and 97/98 first open a workbook  (Excel document).  Pull down the Tools  menu, select Macro>  and choose Macros...  A dialogue box appears into which you need to type the name of the macro function you wish to create.  For this example, the function name is ENGRD241.  Then click on Create.  You can now enter a macro function.  Note that the program initially assumes you are trying to write a subroutine.  You will need to change the initial "Sub" to "Function".  The Visual Basic editor will automatically change the ending to "End Function".  
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When you are finished entering the body of your new function, you can click on the x box in the upper right hand corner (PC; for Mac click on the square box in the upper left hand corner) of the window containing your macro to get back to the workbook.  

Here is an example Visual Basic program. Note how the single quote is used to begin comments.  Also note that variables are declared as they are used.  
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Function ENGRD241(p, n)
Sum Integers to the power p from 1 o n and
returns the sum as the value of the function
ENGRD241
Program by JR. Stedinger, 2/2000

sum =0
If n <= 0 Then

n=t
Elselfn> 10 Then

n=10
End It
Fori=1Ton

Sum = Sum + i+ p
Next |

ENGRD241 = Sum

Following command needed to end the function,
End Function
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 To return to the macro for editing, pull down the Tools  menu, select Macro>  and choose Visual Basic Editor.  If the macro does not appear, select it from the list of Modules in the Project window.  
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Other Useful Macro Information
· To insert the function in a cell, in the worksheet you can just type into a cell:



= ENGRD241( 2, 4.5),   

or



= ENGRD241( A2, A3)            where cells A2 and A3 contain the values of p and n. 

· Subroutine versus Function macros.  Function macros return values and can be inserted into equations in Excel just like the standard functions (i.e., =sum(A3:D7) ).  One can also create Subroutine macros, which do NOT return values.  Subroutines are useful for performing routine tasks.  For example, you can establish a subroutine to open a new workbook and format the top of each sheet with standard homework headings.  Programming subroutine macros is beyond the scope of this course.  If you would like to know more, see the online help for the Visual Basic Editor.  

· Creating more macros.  To create another function macro, from the Visual Basic Editor, pull down Insert   and select Module.  This will give a new module window.  

· Arithmetic operations use   ^   *   /   +   - .

· Logical tests can employ the comparisons   <   <=   >   >=   =   and   <>

· Arrays can be dimensioned with    Dim Array(2,10)
· Built-in functions can be employed: Sin, Cos, Asc, Abs, Exp, Log, Rnd,  etc.

· Note that Pi is not a recognized constant.  It can be declared as a variable and set equal to 3.141592654 .  

· Do Statement  Excel also allows Do statements to be used.  They have the following format:
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Function iter(n)
This program counts iterstions and checks
the loop before the first iteration
writen by J. Stedinger 2/2000.

counter = 0

Do While (counter - n)
counter = counter + 1
Loop

iter = counter
End Function

Function itera(n)
This program counts iterstions and checks
the loop after the first iteration
Writen by J. Stedinger 2/2000.

counter = 0

Do
counter = counter + 1
Loop While (counter - n) <= 0

iter2] = counter
End Function
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There are a great many other capabilities that are available.  

You can use a manual or browse through the help files available with the Visual Basic Editor.   

Goal Seeking
Excel includes a facility for goal seeking which means that Excel can find the root of a single nonlinear function.  It also includes a solver which is more general and can find the root, or the maximum or minimum of a function of several variables.  The feasible domain may be constrained.  Use of solver is described below.  

Solver
The Solver function in Excel will maximize (or minimize) an objection function subject to any number of constraints on the solution.  The solver function allows you to find the value of many variables.   We will illustrate this using a simple example. 


Find the value of c that yields y=-0.5 where:



y=-b + ((2b-4ac)/2a)^0.5  (quadratic equation)



a=4



b=16



c=1   (initial guess of c)




1.  Set up the following spreadsheet:
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2.  From the Tools menu select Solver and input the following values into the window:
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3. Select Solve.  The following window should appear and your result should appear in cell A4. 
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· You can now view several reports for your problem.  

· Answer Report - will show you the original and final values for your target cell and adjustable cell.


b.
Limits Report - lists the target cell and the adjustable cells with their respective values, lower and upper limits, and target values. 

c.
Sensitivity Report - provides information about how sensitive the solution is to small changes in the formula, the Set Target Cell box, the Solver Parameters box, or the constraints.

For more information on this subject you may refer to the Excel Help Menu. 

The Options dialog box within Solver will let you control advanced features of the solution process, load or save problem definitions, and define parameters for linear and non-linear problems.  Each option has a default value that is appropriate for most solutions.  See the Excel Help Menu for more information. 

Numerical Precision
Just for the record, Excel carries 14 decimal digits with a positive floating point number range of  2.2E-308 to 1.8E+308. 

Other Features

Excel has many other features including (if installed; see Add-in under Option): 


Spelling checker (under Options menu)


Analysis of multiple cases (Scenario Manager under Formula)


Analysis of Combinations of Parameters (What if under Formula)


Table of results (substitute specified values into formulas, Data menu)


Parse (reorganized data into columns, Data menu)


Outlining (under Formula)


Cell Notes/Comments (Note under Formula)


Slide show with sound (special worksheet in Macro Library folder)


Sorting (under Data menu)


Find/Replace (under Formula menu)
Excel has many database capabilities that allow records to be stored on the spreadsheet.  One can then perform  single- and multiple-field sorts, and extract records selectively based on the satisfaction of specified criteria.  Statistics can be calculated for only those records that meet certain criteria. 
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Some Financial Functions in Excel

Net Present Value for a Series

NPV(interest-rate, value-1, value-2, value-3, ... )

NPV(interest-rate, range-of-values)

Definitions for other functions

PV, FV, NPER, PMT and RATE compute value of one of following given values of all of others.  

Start with a problem whose answer you know.


rate
 interest rate per period


nper
number of periods


pmt
periodic payment every period


pv
present value of series of payments plus final payment


fv 
final payment at end of last period 


type
type indicates when during periods payments are made.  

type = 0 if 1st payment occurs at end of 1st period;  

type = 1 if payments are made at beginning of the periods.  

This argument can be omitted.


guess 
optional guess of value of rate


pv * [1+rate]nper  +  pmt * [1+rate*type] * [ (1+rate)nper – 1]/rate  +  fv  =  0

Present Value Functions 

PV(rate,nper,pmt, fv,type)


Present value of a series with final payment

FV(rate,nper,pmt,pv,type)


Future value of a payment pv plus a series

NPER(rate,pmt,pv,fv,type)


Number of payments of investments

PMT(rate,per,nper,pv,fv,type)


Periodic payment for an investment

RATE(nper,pmt,pv,fv,type,guess)

Rate of Return

IRR(range-of-values,guess)  --  Internal rate of return

MIRR(range-of-values,guess, safe, risk)  --  Modified internal rate of return

Depreciation Functions

SYD(cost,salvage,life,per)


 Sum-of-years' digits depreciation schedule for:


Cost
Initial cost of the asset


Salvage 
Value of asset at end of depreciation period


Life 
Number of periods over which asset is being depreciated


Per
The period for which depreciation is to be calculated;



thus per = 1 yields the scheduled depreciation for the



first period, per = 2 for the second and so forth up to Per = Life.

SLN(cost,salvage,life)


Straight-line depreciation value for every year given Cost, Salvage 


and Life  are as defined above.

DDB(cost, salvage,life,per)


Double-declining balance depreciation schedule.  


Cost, Salvage and Life and Period are as defined above.
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